Investigating an issue with Third party services. Payment providers maybe affected

Minor incident Third party services Payment providers
2022-10-13 07:14 UTC · 8 hours, 23 minutes

Updates

Resolved

The incident has been resolved. PayPal is operating normally. We thank you for your patience while the incidents was working to solve.

October 13, 2022 · 15:38 UTC
Monitoring

An incident has happened on PayPal end: https://www.paypal-status.com/history/eventdetails/62824

In this period, PayPal users may be experiencing “Things don’t appear to be working at the moment. Please try again later.” errors when making a payment.

PayPal technical teams are actively working towards resolving the issue.

We will provide an update when the incident is resolved.

October 13, 2022 · 07:21 UTC
Investigating

We are investigating Payment providers issues to understand the full impact and mitigate this problem.
More updates to follow shortly.

October 13, 2022 · 07:17 UTC

← Back