Investigating an issue with Storefront. Storefront domain maybe affected

Minor incident Storefront Storefront Domain
2022-11-03 01:00 UTC · 36 minutes

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

November 3, 2022 · 02:26 UTC
Monitoring

A fix has been implemented and we are monitoring the result. In this period, domain cannot buy or renew. We will provide an update when the incident is resolved.

November 3, 2022 · 02:25 UTC
Issue

We are investigating Storefront domain issues to understand the full impact and mitigate this problem.
More updates to follow shortly.

November 3, 2022 · 02:22 UTC

← Back