Investigating an issue with Domain provider. Purchasing domain maybe affected
Minor incident
Third party services
Domain providers
2023-03-05 08:15 UTC
· 4 hours, 13 minutes
Updates
Resolved
March 5, 2023 · 12:28 UTC
The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.
Monitoring
March 5, 2023 · 09:12 UTC
A fix has been implemented by our domain provider and we are monitoring the result. In this period, you can’t buy domains temporarily. We will provide an update when the incident is resolved.
Issue
March 5, 2023 · 09:04 UTC
We are investigating domain purchasing issues to understand the full impact and mitigate this problem.
More updates to follow shortly.
← Back