Investigating an issue with checkout . checkout service maybe affected

Minor incident Checkout Storefront Checkout Page
2023-04-25 14:58 UTC · 4 minutes

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

April 25, 2023 · 14:48 UTC
Issue

We are investigating checkout service issues to understand the full impact and mitigate this problem.
More updates to follow shortly.

April 25, 2023 · 14:33 UTC

← Back