Incident Monitoring Report for PrintBase/PlusBase Klarna EU payment method

Minor incident Checkout Payment Provider
2023-11-17 08:42 UTC · 1 hour, 49 minutes

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

November 17, 2023 · 10:32 UTC
Investigating

A fix has been implemented and we are monitoring the result. During this time, the Klarna EU payment method may not be accessible. Rest assured that other payment methods will still be working as normal. We will provide an update when the incident is resolved.

November 17, 2023 · 08:47 UTC
Issue

We are investigating payment provider issues to understand the full impact and mitigate this problem.
More updates to follow shortly.

November 17, 2023 · 08:42 UTC

← Back