Investigating an issue with Checkout. Payment Provider on Creator stores maybe affected

Minor incident Checkout Payment Provider
2024-02-02 02:47 UTC · 51 minutes

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

February 2, 2024 · 03:38 UTC
Monitoring

A fix has been implemented and we are monitoring the result. In this period, Creator store’s payment method may not be available. ShopBase, PrintBase and PlusBase are not affected. We will provide an update when the incident is resolved.

February 2, 2024 · 02:49 UTC
Issue

We are investigating Payment Provider on checkout issues of Creators store to understand the full impact and mitigate this problem.
More updates to follow shortly.

February 2, 2024 · 02:47 UTC

← Back