Investigating an issue with Dashboard. Balance maybe affected

Major incident Admin Dashboard Balance
2024-04-04 04:19 UTC · 8 hours, 27 minutes

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

April 4, 2024 · 12:45 UTC
Monitoring

Our auto-detect fraud system has technical issues, resulting in order profit being held. A fix has been implemented and we are monitoring the result. New orders will not be affected. In this period, merchants may see their Balance Account have a negative amount. We will provide an update when the incident is resolved.

April 4, 2024 · 04:20 UTC
Issue

We are investigating negative Balance issues to understand the full impact and mitigate this problem.
More updates to follow shortly.

April 4, 2024 · 04:19 UTC

← Back