Investigating an issue with Admin Dashboard

Minor incident Admin Dashboard PrintHub Order Admin Balance
2024-12-25 11:10 UTC · 13 minutes

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

December 25, 2024 · 11:24 UTC
Investigating

A fix has been implemented, and we are monitoring the results. During this period, Store Admin may not be accessible. We will provide an update when the incident is resolved.

December 25, 2024 · 11:15 UTC
Issue

We are investigating Admin Dashboard issues to understand the full impact and mitigate this problem.
More updates to follow shortly.

December 25, 2024 · 11:10 UTC

← Back