Investigating an issue with storefront maybe affected
Major incident
Storefront
Storefront Home Page
Storefront Collection View
Storefront Product View
Storefront Order Detail
Storefront Catalog API
Storefront Product Review
Storefront Product Recommendation
Storefront Domain
2025-03-16 19:19 UTC
· 1 minute
Updates
Monitoring
March 16, 2025 · 19:18 UTC
The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.
Investigating
March 16, 2025 · 19:15 UTC
We are investigating storefront issues to understand the full impact and mitigate this problem.
More updates to follow shortly.
← Back