[PrintBase/PlusBase] Investigating an issue related to EU payments. Payments via EU Payments are temporarily unavailable.

Major incident Checkout Payment Provider
2025-04-07 22:18 UTC · 2 days, 12 hours, 22 minutes

Updates

Issue

The payment method will be temporarily unable to checkout payments. We will notify after the service is live again.

April 10, 2025 · 10:40 UTC
Monitoring

We will provide an update when the incident is resolved.

April 7, 2025 · 23:04 UTC
Issue

In this period, payments via EU Payments are temporarily unavailable.
Your customers cannot checkout via EU payment methods on PrintBase & PlusBase stores.
We will provide an update when EU payment methods is ready to use again.

April 7, 2025 · 22:18 UTC

← Back