Investigating an issue with Checkout. Fast Checkout maybe affected

Major incident Checkout Fast Checkout
2025-10-02 06:52 UTC · 36 minutes

Updates

Update

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

October 2, 2025 · 07:45 UTC
Update

A fix has been implemented and we are currently monitoring the result. During this period, stores with Speed Checkout enabled may experience errors. We will provide an update once the incident is fully resolved.

October 2, 2025 · 07:28 UTC
Issue

We are investigating Fast Checkout issues to understand the full impact and mitigate this problem.
More updates to follow shortly.

October 2, 2025 · 06:55 UTC

← Back