Incident Update Report for 3D product launching on PrintHub & PrintBase

Minor incident Admin Dashboard
2020-12-23 07:32 UTC · 21 minutes, 51 seconds

Updates

Resolved

The issue with product launching on PrintHub and PrintBase has been fixed. Campaigns that have been launching during the incident time will be automatically republished.

December 23, 2020 · 07:54 UTC
Monitoring

We are monitoring the cause of the system delay. This issue is estimated to be fixed in the next 30 minutes.

December 23, 2020 · 07:35 UTC

← Back