Incident Update Report for Campagin Dashboard

Minor incident Admin Dashboard
2021-05-13 04:35 UTC · 38 minutes, 40 seconds

Updates

Resolved

This incident has been resolved.

May 13, 2021 · 05:14 UTC
Issue

Some solutions are being applied. Launching Campaign may took longer than usual.

May 13, 2021 · 04:37 UTC

← Back