Incident Update Report for Product and Collection Dashboard

Minor incident Admin Dashboard
2021-05-13 10:23 UTC · 6 hours, 8 minutes, 53 seconds

Updates

Resolved

This incident has been resolved.

May 13, 2021 · 23:32 UTC
Issue

We are investigating sync issues on the Product and Collection dashboard.

May 13, 2021 · 10:27 UTC

← Back