Admin Dashboard Signin Down

Major incident Admin Dashboard
2021-06-30 13:11 UTC · 21 minutes, 14 seconds

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

June 30, 2021 · 13:32 UTC
Issue

We are investigating Admin Dashboard issues to understand the full impact and mitigate this problem. More updates to follow shortly.

June 30, 2021 · 13:31 UTC

← Back