Incident Update Report for Admin Dashboard

Major incident Admin Dashboard
2021-07-01 08:37 UTC · 15 minutes, 49 seconds

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

July 1, 2021 · 08:53 UTC
Investigating

We are investigating Admin Dashboard issues to understand the full impact and mitigate this problem. More updates to follow shortly.

July 1, 2021 · 08:44 UTC

← Back