An issue has occurred from Checkout Page. Checkout Page maybe affected

Major incident Checkout
2021-08-29 00:00 UTC · 52 minutes, 57 seconds

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

August 29, 2021 · 00:52 UTC
Issue

We are investigating Checkout Page issues to understand the full impact and mitigate this problem. More updates to follow shortly.

August 29, 2021 · 00:46 UTC

← Back