An issue has occurred from Admin Dashboard. Sign up process might be affected

Minor incident Admin Dashboard
2022-04-01 15:01 UTC · 16 minutes, 45 seconds

Updates

Resolved

The incident has been resolved. Service is operating normally. We thank you for your patience while we worked on resolving the issue.

April 1, 2022 · 15:18 UTC
Issue

An issue has occurred from Admin Dashboard. The sign-up process might be affected. We will provide more updates as soon as possible.

April 1, 2022 · 15:06 UTC

← Back